Opening the Game Settings Window on Beyond Good & Evil

NunobPinto

New member
Joined
Apr 1, 2022
Messages
3
Hi!

As of Proton 7.0-2 Beyond Good & Evil runs almost flawlessly on the Deck, apart from some sporadic graphical glitches here and there, but unfortunately the default dialog language is french, which can only be changed in the game settings window, which when opened throws the following error:

15130_screenshots_20220430222923_1.jpg


Does anyone know if there's a workaround and/or fix for this? I haven't tinkered at all so far, but I'm trying to come up with a solution as well and will update if there's any news.

Thanks
 

Kupfer

Well-known member
Joined
Feb 3, 2022
Messages
155
Can't try it right now, but maybe this can help, which I found here :
In the game folder, edit the file "Installscript.vdf"

Remove every language entries in the registry part that you don't want.

Example for the french language:
Before:
"Registry"
{
"HKEY_CURRENT_USER\\SOFTWARE\\Ubisoft\\Beyond Good & Evil"
{
"dword"
{
"french"
{
"SelectedLanguage""0"
}
"english"
{
"SelectedLanguage""1"
}
"german"
{
"SelectedLanguage""2"
}
"spanish"
{
"SelectedLanguage""3"
}
"italian"
{
"SelectedLanguage""4"
}
"dutch"
{
"SelectedLanguage""5"
}
"brazilian"
{
"SelectedLanguage""6"
}
"koreana"
{
"SelectedLanguage""7"
}
"japanese"
{
"SelectedLanguage""8"
}
"tchinese"
{
"SelectedLanguage""9"
}
"schinese"
{
"SelectedLanguage""10"
}
"russian"
{
"SelectedLanguage""11"
}
}
}
"HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Ubisoft\\Beyond Good & Evil"
{
"string"
{
"Install Path""%INSTALLDIR%"
}
"dword"
{
"french"
{
"InstallLanguage""0"
}
"english"
{
"InstallLanguage""1"
}
"german"
{
"InstallLanguage""2"
}
"spanish"
{
"InstallLanguage""3"
}
"italian"
{
"InstallLanguage""4"
}
"dutch"
{
"InstallLanguage""5"
}
"brazilian"
{
"InstallLanguage""6"
}
"koreana"
{
"InstallLanguage""7"
}
"japanese"
{
"InstallLanguage""8"
}
"tchinese"
{
"InstallLanguage""9"
}
"schinese"
{
"InstallLanguage""10"
}
"russian"
{
"InstallLanguage""11"
}
}
}
}
After:
"Registry"
{
"HKEY_CURRENT_USER\\SOFTWARE\\Ubisoft\\Beyond Good & Evil"
{
"dword"
{
"french"
{
"SelectedLanguage""0"
}
}
}
"HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Ubisoft\\Beyond Good & Evil"
{
"string"
{
"Install Path""%INSTALLDIR%"
}
"dword"
{
"french"
{
"InstallLanguage""0"
}
}
}
}
 

NunobPinto

New member
Joined
Apr 1, 2022
Messages
3
Can't try it right now, but maybe this can help, which I found here :

Before:

After:
I tried it yeah, the language remained unchanged though, my installscript.vdf looks like this:



I also noticed that the unchanged installscript.vdf on my install folder also had

Code:
"string"
{
"Install Path""%INSTALLDIR%"
}

in the "HKEY_CURRENT_USER\\SOFTWARE\\Ubisoft\\Beyond Good & Evil" closure, while on the tutorial it's not there. I tried it both with and without that snipped of code and it didn't work either way.
 
Top Bottom