Games Freezing or Not Launching

juicebox

New member
Joined
Jul 18, 2022
Messages
3
I have set up a fresh install of HoloISO and when launching some games, they either freeze or don't launch.

So far, I've tested with Hitman 3 and Elden Ring. Hitman 3 freezes on the intro videos, and mangohud stops updating. Elden Ring displays a white screen (probably the Namco Bandai splash screen) and freezes, or is stuck at the spinning Steam logo.

With Hitman 3, launching in fullscreen mode from the desktop works, I was able to get in-game and run around for a bit. With Elden Ring, launching in desktop mode does not work either, even launching without the game overlay.

I've attached logs from each game (launching with PROTON_LOG=1 from the desktop).

System specs (from neofetch):
OS: SteamOS Holo x86_64
Host: OptiPlex 3060
Kernel: 5.13.0-valve21-2-neptune-02209-g2a5bdc1102a0
Packages: 875 (pacman), 6 (flatpak)
Shell: bash 5.1.16
Resolution: 2560x1440
DE: Plasma 5.23.5
CPU: Intel i5-8400 (6) @ 4.000GHz
GPU: AMD ATI 03:00.0 Device 743f
GPU: Intel CoffeeLake-S GT2 [UHD Graphics 630]
Memory: 1816MiB / 7774MiB

The AMD GPU is a Sapphire RX 6400


Edit: Elden Ring works fine if I launch before Hitman 3. It seems like Hitman 3 is the only one with issues or is maybe causing a process to hang. I launched Elden Ring after launching Hitman 3 and it getting stuck, and it did the "spinning steam logo" and restarted the gamescope session.

Playing around with the Hitman 3 settings, I was able to get in-game once by disabling vsync and using fullscreen instead of exclusive fullscreen.

Edit 2: Attached log from launching Hitman 3 from gamescope session
 

Attachments

  • logs.zip
    47.4 KB · Views: 3
  • steam-1659040.zip
    30.1 KB · Views: 2
Last edited:

juicebox

New member
Joined
Jul 18, 2022
Messages
3
It's still an issue, but the issue is with Proton and not HoloISO itself right now. Need to wait for a Proton update to fix the issue. I haven't tried with non-Valve versions of Proton either (i.e. Proton-GE).
 

markipolo

Active member
Joined
May 23, 2022
Messages
154
It's still an issue, but the issue is with Proton and not HoloISO itself right now. Need to wait for a Proton update to fix the issue. I haven't tried with non-Valve versions of Proton either (i.e. Proton-GE).
oh I see, thanks for clarifying the issue. That said, there's plenty to look forward to in the future. 👍
 
Top Bottom